2020 - RACHEL-Pi Images

Hello everyone,

These are the latest RACHEL-Pi images. Please read through the readme instructions pdf for the image to get started. This post will be updated regularly with new images. Let me know how it goes!

James

Latest Downloads

A new image will be available soon

Important Notes

  • If you are using an older RACHEL-Pi image please update to the latest to fix issues with Kolibri and Kiwix when it’s available

  • Please boot with only your boot device inserted and wait until you can see the RACHEL interface before using a USB device for Kolibri importing

  • Please set up your Kolibri facility first by clicking on the Kolibri module and following the setup instructions. The Pi will take an extra minute or more to properly shut down until it has been set up. Always wait for the green lights to finish flashing before shutting down.

  • The Raspberry Pi 2 is supported again

  • Wikipedia modules will be synced automatically and no longer require a reboot after installing, hiding, or unhiding them.

  • As KA-Lite is no longer in active development according to https://learningequality.org/ka-lite/, KA-Lite will not be included in the latest images. It is strongly recommended that you start with Kolibri for new deployments. If you need KA-Lite support with a Raspbian buster image and en-kaos is not enough, please let me know.

  • For use with the Raspberry Pi Zero W please see the “Optimizing for the Raspberry Pi Zero W.pdf” included in the tutorials

Older Downloads

  • Older images can be found on the World Possible FTP by connecting to dev.worldpossible.org with the user/pass “anonymous”. The images are in the rachelpi_64EN/rachelpi_2019/ folder.

Updates

Updated 03/17/2020

3 Likes

9 posts were split to a new topic: Cannot Download RACHEL-Pi Image from FTP

Thanks James @jamesk
particularly for the tutorials

1 Like

You’re welcome Howard. Let me know if you have any suggestions. The admin user case fix is in this image as well.

Hi, James,

I have had trouble getting the en-wiktionary module to get the href to the search index right. I had to correct the index file name.

Thanks for the good work. We will be using this in Uganda.

1 Like

Hi @chuckroast,

You’re welcome and I’m happy to help! That’s great to hear that you’ll be using RACHEL-Pi in Uganda.

I will download and take a look at en-wiktionary to see what the issue is and a fix for it. It will be tomorrow in about 12 hours or so as the internet is a bit slow here right now. Hopefully there’s a quick fix.

James

@chuckroast - I have downloaded en-wiktionary and everything seems to be working on my end. Did you install through the admin user interface or through a transfer directly to the device?

James, Sorry. It wasn’t Wiktionary, It looks like Wikihow searches aren’t happening
in the front menu or internal menus. I tried “Family” in
the front menu, “Dogs” from the Pets page, and under Philosophy I tried “atheism”. “Suggestions” drop down when entering, but no
results after pressing the enter key.

Hi @chuckroast,

No problem. Are you using “en-wikihow” or “en-wikihow-static”?

Also just to confirm, is the search bar that’s not working or is it the preset categories that are in a list on the RACHEL page?

James

Thanks for the reply, James.
I believe the full en-wikihow. It’s the search bars.
The preset links work fine.

One other question: If I just manually copy en- modules up to /var/www/modules is there a way to kick off an index scan so that the new module is indexed properly in the home menu?

You’re welcome @chuckroast. I’ll have to download this to see what’s up. I have en-wikihow-static and the search index works in that for me but maybe something is different in en-wikihow. Since it’s 13GB it will probably be a while.

There should be a tutorial called “Transferring modules with WinSCP” included with the image in the Tutorials>Advanced folder that covers transferring things to the device. It’s probably best to do it that way because you’ll want to run “sudo chown -R www-data:www-data /var/www/modules/the_module_name” so it can be deleted at any time in the web interface. If it’s a Wikipedia module you can run the command “sudo systemctl restart kiwix” to update the Kiwix library or you can hide any module in the “modules” page and then hit save. That should trigger one as well.

James

Hi @chuckroast,

I finished downloading en-wikihow. I notice what you said about many of the results not working. I think this is an issue with the .zim file that it uses. I’m not sure how it was made as it doesn’t seem to exist anywhere else so someone must have manually made it for RACHEL. I don’t think it can be fixed without redoing this process.

I think the solution to this is to use “en-wikihow-static” instead which you can find on the FTP or at en-wikihow-static.zip. I searched “family” with it and it seemed to work and show the results. The rachel-index.php for en-wikihow-static has an issue with the main page links as it has “%3A” in place of the “_” character breaking them. You can either open the rachel-index.php file and replace the %3A with _ or I can upload one for you if you decide to go this route.

James

“en-wikihow-static” it is…But there isn’t a “en-wikihow-static” on
the drop list under the “install” function yet.
Guess I will have to download it directly. Ooops. There isn’t a
static version at oer2go either!
Could you put one up?

Thanks for your work, James!

You’re welcome @chuckroast. I don’t have access to oer2go or the server to change any content as I maintain RACHEL-Pi as a volunteer. The link I provided above is the only place that I know has it.

James

Wikipedia for Schools doesn’t install correctly. I can’t
get to links beyond the front page. I installed it from
the RACHEL admin: “install” drop list.

en-WikiBooks links at the top of the main page are inactive, except for the “How To Use”. i.e. “Browse”. Only the Search Bar works. So that one’s out, too

I’m going to revert kiwix-tools to an old version to support the zims. I’m testing a fix right now and will give that to you and put up a new image once I’m sure it works.

James

This will install an older version of Kiwix and an updated script.

  1. Connect your RACHEL-Pi to an internet connection

  2. Download fix-kiwix.zip

  3. Unzip it and transfer it to /var/tmp on your RACHEL-Pi so you have /var/tmp/fix-kiwix

  4. Connect to the pi overSSH or locally

  5. Run command “cd /var/tmp/fix-kiwix”

  6. Run command “sudo python3 fix-kiwix.py”

  7. When it finishes run command “sudo systemctl restart kiwix”

That should fix the issues with wikipedia modules. Hopefully that works for you.

James

WikiBooks: Bad href on the title.
(/wikibooks_en_all_novid_2017-07/) not found.

Search bar works fine, now, tho. Thanks!