Add or Update Content - RACHEL-Plus 2017 Software Release

Perhaps someone else has encountered my issue after running “rsync” and restarting the device: there are no modules listed under the RACHEL banner on the home page, and after successfully logging into the “Admin” link, the admin/modules.php page is entirely blank.

My box is dated around Christmas 2015 … is the rsync geared to such an “old” box?

Thanks! . . . . . . . . Ken

I’m not sure it is, but I think the only change is that your modules have index.htmlf segments in them and the new boxes have rachel-index.php (though the content of those two files is the same). I wonder if you can rename a few modules index.htmlf files and see if that wakes them up.

Yes, my modules all have htmlf files:

cap@WRTD-303N-Server:/media/RACHEL/rachel$ find . -name \*htmlf\*
./modules/infonet/index.htmlf
./modules/GCF/index.htmlf
./modules/scratch/index.htmlf
./modules/hesperian_health/index.htmlf
./modules/medline_plus/index.htmlf
./modules/musictheory/index.htmlf
./modules/powertyping/index.htmlf
./modules/ck12/index.htmlf
./modules/edison/index.htmlf
./modules/practical_action/finished/index.htmlf
./modules/practical_action/index.htmlf
./modules/gcf/index.htmlf
./modules/gcf/index.htmlf~
./modules/ebooks-en/index.htmlf
./modules/PhET/index.htmlf
./modules/PhET/index.htmlf.edit
./modules/understanding_algebra/index.htmlf
./modules/radiolab/index.htmlf
./modules/TED/index.htmlf
./modules/TED/index.htmlf.edit
./modules/iicba/index.htmlf
./modules/wiki_en/index.htmlf
./modules/windows_apps/index.htmlf
./modules/ka-lite/index.htmlf
./modules/math_expression/index.htmlf
./modules/olpc/index.htmlf
./test/mod_one/index.htmlf
./test/mod_two/index.htmlf
cap@WRTD-303N-Server:/media/RACHEL/rachel$ 

Editing a couple of them hasn’t helped … let me try renaming them all.

I could copy all except GCF/ hesperian/ edison/ practical_action/ and ka-lite/

Looking in kalite/, for example, I cannot see why I do not have the permissions to create rachel-index.php.

I note that while the index.htmlf file is owned and grouped by “root”, my new rachel-index.php files are owned and grouped by “cap”.

I rebooted and I still see no modules in either the home page or after logging in to administration. I have nothing to click on.

This may have to wait for @jfield to troubleshoot. Do you have an admin page now? 192.168.88.1/admin.php?

Can you download a full new module and see what happens?

I can log in to admin, but as mentioned above, after successfully logging in I see nothing … a blank page … no opportunity to click on anything or read anything. It is entirely white.

The address bar reads: http://192.168.2.68/admin/modules.php (which matches the IP address of the RACHEL box on my router)

Got it, sorry, I misunderstood.

It might be best to put all the modules on a USB external hard drive (cp modules external) and then just start clean with a USB reformat of the device. Is that an option?

Not for the RACHEL-Plus in Tanzania, which is why I’m practicing on the RACHEL-Plus in Canada.

Where in tanzania is it? We have lots of users there who should have a 500gb external drive we could provision locally.

Still want to get a better answer from jfield but he’s is South Africa at the moment.

Hi - back online. So I’m not sure what’s going on here as I don’t have a device that old to test against. In fact the new admin should work with either rachel-index.php or index.htmlf files (it looks for both). Also, that command shouldn’t delete anything in the modules directory So it’s something else going on here.

My guess is that on the older devices there’s something missing from the PHP installation. If you can show me some of the output from /var/log/httpd/error_log on that device it might help in identifying the problem.

The brute-force solution would be to re-install the system software using the recovery USB, but let’s see if we can figure out what’s missing first because it might be a relatively easy fix…

Ok - finally got a chance to dig into this – and it was an educational experience. Turns out there was no sqlite on the device, which is the database system we use for everything now. I didn’t realize we ever had Pluses without sqlite, but I guess we did!

In the future with devices this old, I would definitely recommend starting with the CAP1 Recovery USB as I had to make lots of tweaks! But I believe I have it all working now, with an updated ka-lite as well – so check it out and let me know!

My Rachel Plus is a 2015 model and I can’t update it or even find where to upload my own content. I get a 404 error when trying various addresses as instructed by information I find in the manual.
Where can I find information on a CAP 1 Recovery USB, or alternatively, can I trade this old one in for a discount on a new Rachel-Plus?
A fresh Install wouldn’t hurt anything since it has been in storage and unused for the last couple of years. If that would be an option for me, could you point me to directions on how to do this?

Thanks,
Rose

Rose, I found this page Create and Use and USB Recovery that claims to work for the 2015 models, but I’ve posted there the problem I am having haven done all of the process and I am awaiting feedback. I hope this helps … perhaps there won’t be problems if you follow the process.

Good luck! . . . . . Ken

1 Like

As @jfield mentioned, we have come a LONG way since we starting building RACHEL. You have the same situation as Ken (@gkholman) posted here. The bottom line is that you have a RACHEL-Plus with a different partition schema then we now use. All that is detailed in the link above. I would recommend updating to our new partition schema. After reading that post, if you have more questions, please don’t hesitate to ask.

1 Like

Thank you Jeremy for the information. I will now go around the schools updating the contents now. I found the video very useful. Thanks once again. Laso Mana, Papua New Guinea

Thank you JField for the information provided, I followed your instructions yesterday and finally managed to get RACHEL -Plus updated with the new version. I will follow same procedure to update the RACHEL Plus that are currently being used in schools. God bless.

1 Like

Hi @jfield

I ran the command on Rachel Plus WRTD 303N. It was okay but when I ran the last command (4), it gave error below. What can I do?

When I want to update add and update modules, its not downloading. It saying’ waiting. Below is the screen shot

Ah, my instructions assumed you were logged into the root account. But I see that is not always the case. I have updated my instructions to include sudo, which will run the command as root, which will have permission to killall lighttpd.

In any case, you can achieve the same thing by restarting the machine. The goal is just to re-load lighttpd, the web serving software, so that it uses the updated files. Either sudo killall lighttpd from the command line, or restarting the device will work.

Let me know if there’s any problem!

I experienced the same problem as @gkholman and @Rose. I went through all the information being exchanged in this forum and ultimately, followed @sam instructions as per @gkholman case. I downloaded the recovery image RACHEL_Recovery_USB_CAPv1_20160707-oldHDschema.img.zip. This image bring the RACHEL Plus back to life. Unfortunately, I noticed that Wikipedia and few other modules were in France language.

I researched of few more tips but didn’t work out. The next option I had in mind is to delete and reinstall again but the file sizes were big so had no choice. I had no choice so I decided to run the command posted by @jfield on the root. This is the command
Run the following command, making sure to get everything on one line: sudo rsync -Pavz --exclude modules --exclude /admin/admin.sqlite --exclude ‘.*’ --del rsync://dev.worldpossible.org/rachelmods/contentshell/ /media/RACHEL/rachel/

Run the following command: sudo killall lighttpd

and Reboot
Bingo…Bingo. All working very well…
Thank you all for sharing your ideas and knowledge. God bless.
Laso

I’m very glad that worked for you! Sorry for the hiccups along the way – it can be tough figuring out what went wrong remotely with many different types of hardware and software out there. Thanks for your patience, and I hope your RACHEL runs smoothly and helps many people going forward!

1 Like