Best February 2020 Rachel Pi deployment solution

The USB3 port was a really exciting feature of the Pi4 release, but without USB booting support they are pretty well useless for RACHEL-Pi. The current official RACHEL code base doesn’t have USB module loading support and all of the images that I have released so far have just been getting the official code working with the latest operating systems/devices.

I have developed USB module loading separately from that code base as well as other features, modules, UI updates, and admin interface changes. USB module loading works in my testing with Pi4 and the USB3 ports, but I’m not really sure how to proceed. Anything I release at this point isn’t part of the official RACHEL code, but the official code hasn’t really changed so any new official images will basically be the same.

Thanks for this James. It seems to me best to wait until usb booting support is available on Pi4. Then Rachel could be installed on an ssd which is just plugged into one of the usb3 ports. This would provide a simple deployment solution of Pi4, ssd and power chargers. If the Pi4 fails for any reason, then it would just be a swap to another Pi4. Guess this deployment architecture works today with a 3B+ but via usb2 and only 1Mb memory on the Pi.

You’re welcome Trevor. It sounds like both @SHOMI and @Giakonda have had success with the Pi 4 with a MicroSD, but if you’re set on using an SSD the 3B+ is the highest supported model.

This post is a good comparison of the features of each device and it seems the Pi4 beats out the 3B+ in every aspect. Without real world testing and watching the resouce usages with something like htop or top, I’m not entirely sure an SSD over USB2 is any better than a high speed MicroSD on the Pi4 or if more RAM makes much of a difference. Whatever you decide to go with, it’s always best to have backup options in case one fails due to an improper shutdown or something else. MicroSD cards are popular for that since they’re cheap and so small it’s easy to ship them.


Most used by teachers in Siavonga are the Kolibri African Story books, They are in Tonga Nyanga and Bembe.
Also popular are the CK 12 books, Hesperian Health guides Practical Action and the Teacher training module.

Hi Giakonda.
In a recent blog you mentioned Zambian language books on Rachel Pi can these be loaded on a Rachel server based platform and if so where can I get them. Looking forward to your reply.
Pat Bergin - Propel Education supporting Linda Community School, Lusaka

I get them from kolibri, log into your pi with a browser as usual. I guess you use as the IP address. but instead use
This gives you access to kolibri
you will have to setup kolibri if you haven’t already done that.
I have some notes on kolibri on

1 Like

I hope to be in Lusaka/Siavonga towards the end of February if you would like to meet up

Update on my February Rachel Pi deployment. I downloaded the Jamesk buster version of 29-09-2019 and installed this on a 64 Gb usb device which I then used on a 3B+ to download about 57Gb of content - OER2GO and Kolibri modules. All working great. I have ‘cloned’ the 64Gb usb onto a 128Gb sd card using dd. The sd card is now working fine on my newly acquired 4B4. The only issues I have are:

(a) I cannot seem to be able to measure the temperature of the 4B4. Bash will not recognise vcgencmd measure_temp
(b) my sd card shows up as only have the same spare space as the 64 Gb usb i.e. not the additional space that I want from the 128Gb card. How do I extend the space available for additional Rachel modules?

The 4B4 does seem to enable content to be displayed a bit quicker, but I am not ‘blown away’ in making a comparison with the 3B+.

Glad it’s working. These should be the solutions

a) I think it’s possible the /opt/vc folder is missing or the command alias is. You can try running the full path, “/opt/vc/bin/vcgencmd measure_temp” instead and see if it runs. If it doesn’t you can run “sudo rpi-update” and it should be restored on reboot.

b) You will need to run “sudo raspi-config” and run “extend filesystem” to take up the entire space. The RACHEL-Pi images automatically resize the file system on the first boot, but it only happens the first time. If you’ve cloned a smaller card to a larger card that’s already been run once you’ll have to resize manually.

There are a few things that the Pi4B has that should improve the performance but without USB boot the MicroSD bottleneck is still there. It’s definitely faster for me during development and testing, but serving content requires reading off of the storage device.


Thanks James. So clear and so quick to implement. Now all working fine. I did initially have some difficultly with the sudo rip-update. Got !!!failed messages about ca-certificates and time not being set correctly. Unplugged everything. Plugged it all back in again. Tried again and it worked.

I have seen a James Chambers tutorial on booting the 4B4 from the usb drives. I am going to follow this and see if I can get Rachel running this way. I hope the benefit would be c. 300 MBS upload speeds?

You’re welcome Trevor. I’m interested in the results of your USB test. That method is very picky with devices so I haven’t considered it an official option. It would be nice to know what speeds RACHEL-Pi on a Pi4B should be capable of though.

Followed the set of instructions from James A Chambers and everything works fine. The only issue is I have used the Raspbian Buster image from 26-09-2019 instead of your Rachel image!!! Do it all again tomorrow with the right image!

As feedback on the process setout by James A Chambers, it was very straightforward to follow and apply. I have used a Sandisk Extreme portable 250Gb SSD.

That’s great. There shouldn’t be any issue with the same process on a RACHEL-Pi but I hope it works out…

Thanks again James. It has worked fine and I now have Rachel running on my 4B4 from a Sandisk Extreme 250Gb SSD. Everything just loads faster.

This is probably more of a linux question than Rachel, but I would really like to copy Rachel/Kolibri modules that I have already downloaded on an sd card to my new SSD rather than downloading again. I guess if I can identify the drive/path(s) I can carefully use dd to do this?

That’s great @TrevorG. A new Raspbian release was just put out today but there’s no sign of USB boot so that’s probably the only USB option on the Pi4 for a while.

There’s a tutorial included with the images called transfering modules with WinSCP. That’s probably the best way to back up modules to a PC to be transfered again. The other option is to make a clone the drive using something like win32disk imager and then open the image file with 7zip. Once inside 7zip there are two files, open the bigger one and you should be able to browse the file system to /var/www/modules and just drag those out to your desktop.

@giakonda has a tutorial on his site about migrating Kolibri data. I’ll try and find the link again.


It’s at under resources. I’m going to review it soon so I would welcome your comments

1 Like

@TrevorG I keep the kolibri modules on an external drive using the built in process on kolibri. I then transfer them as required. If you have multiple machines on a network then the network transfer can work well

Upgrading to the new Raspian image and thanks for the kolibri-starter pdf Giakonda. Really clear and easy to follow. I am backing up my Kolibri modules from a 128Gb sd card to a 128 Gb usb which I will use to load further Rachel Pi devices. I am impressed with the loading speed from the Sandisk SSD RPi4B4 combination. I have not tweaked clock speeds. Guess this might add further benefits but also increase device heat.

Hi @giakonda,

I am trying to back up Kolibri content from my sd card to a usb device. Kolibri cannot find the the usb device? I have looked on the Learning Equality forum to see if there might be some guidance on this but I have not really found anything that helps. My RPi4B4 is booting from the sd card with Rachel and Kolibri modules etc. The USB device is plugged in to one of the usb3 slots. Any ideas on why Kolibri might not be able to recognise the usb?

Some usb devices are setup with the exfat file system if that is the case then Raspbian won’t read it without first installing the software:
sudo update
sudo upgrade
sudo apt install exfat-fuse exfat-utils
Give this a try