GCF modules downloads with multiple videos that are the same

I spent some time today adapting the Ubuntu local installer to work for Raspbian x86 desktop. This is the process that should work to install it.

  1. Install Raspbian x86 desktop
  2. run sudo raspi-config
  3. set your locale and exit raspi-config
  4. run sudo apt-get update
  5. run sudo apt-get upgrade -y
  6. reboot
  7. download raspbian_x86_local_12_03_2019.zip
  8. extract the zip to /var/tmp
  9. open a terminal and run cd /var/tmp/installer
  10. run sudo python installer.py
  11. When the installation is done reboot

rachel is available locally at 127.0.0.1 or http://www.rachel.com and anyone on the same network can access it at the ip address assigned to it by the router.

I don’t think adding dhcp as part of an automated installer for PC is something that’s going to be easy. I have tried before without success. For rachel-pi you can try editing /etc/dnsmasq/dnsmasq.conf and adding a range at the end for the eth0 interface and see what happens. Currently it will look like this

interface=wlan0
  dhcp-range=10.10.10.100,10.10.10.199,255.255.255.0,24h

You can try adding the following and see what happens

interface=eth0
  dhcp-range=11.11.11.100,11.11.11.199,255.255.255.0,24h

you will have to reboot and you may have to run sudo systemctl daemon-reload as well. I will be looking at this again soon. The IP address does show on this because the ethernet interface is named “eth0” so the Ubuntu installation likely doesn’t show the IP address because the ethernet interface is not named “eth0” on that installation so the code will have to be changed to match. Let me know how it goes and I can change things if there’s an issue. Hope it works.

James

1 Like

I can’t thank you enough for your support James. Truly appreciate it.
Kind Regards Howard

1 Like

You’re welcome Howard. I’m happy to help with the great work you’re doing.

James

1 Like

Hi James, the first run through of installer.py failed on net-tools
I installed them manually with sudo apt-get install net-tools and then re-ran sudo python installer.py
This time the whole process ran without a hitch.
After reboot RACHEL worked fine.
I was delighted to see the IP addresses were back.
Thanks
Howard

Hi Howard. That’s great that it’s working. Let me know if you run into any other issues with it.

I’m not sure why it would fail on installing net-tools unless maybe the repository was down. Do you remember if it said “command failed” or was there another message like a 404 error on install?

It failed the first time and the script stopped.
Everything was fine after the manual command and rerun.
thanks

1 Like

Hi @jamesk
I installed Raspbian from bare metal and then ran your installer and this time there was no errors and Kolibri and RACHEL but worked without a hitch.
I don’t have any Idea what went wrong previously but I don’t think it had anything to do with your side of things

That’s great Howard. Thanks for the follow up. I think sometimes the package repositories have issues because I’ve had 404 errors a few times lately. When that happens I generally start fresh because parts of the installer will write settings to files twice.

James