RACHEL-Pi Image for Raspbian Stretch


I am interested in the other resizing materials you have. I've left several master copies with the group in Haiti and a process to duplicate if needed. I would like to work on the resizing the images to make it more portable and accessible via my cloud drive. I just have not had much time to get back into this since I've returned from Haiti. 



These are the steps that I used to enable automatic filesystem resizing. To make this work you’ll want to implement these changes on the last time you boot before making an image of the device

  • Add “quiet init=/usr/lib/raspi-config/init_resize.sh” to the end of /boot/cmdline.txt
  • Place the resize2fs_once file into /etc/init.d/
  • sudo chmod +x /etc/init.d/resize2fs_once
  • sudo update-rc.d resize2fs_once defaults
  • sudo systemctl enable resize2fs_once
  • Shut down
  • Make an image with win32diskimager and put it on a USB drive
  • Boot into Raspbian and mount the USB drive to /media/USB
  • run pishrink on the image with the resizing option disabled.

When you flash that shrunken image to another device it should resize to take up the entire filesystem on the first boot. I hope this helps.


1 Like

@jamesk Thank you for the good work. I deployed a RACHEL-Pi image on a Raspberry pi 3B a couple of months ago and it worked as expected. Recently, I got a raspberry pi 3b+ and would love to install one on it. I understand that the version i previously installed was the KA-lite version and due to very poor internet services, would prefer to have the same platform on the new Raspberry pi. This is because it would be easy for me to move the modules from one device to another.

Going through multiple threads on the platform, I found out that there is a installer script for such installation. Unfortunately, I have been unable to download it both on my Laptop and phone. Could you help supply a valid link to the ka-lite install script?

Also, is my plan of action a good one? I hope to leverage on the multiple modules that came with the previous image and deploy this with minimal internet data services .

Thank you very much.

Hello @Taiwo

You’re welcome and I’m always happy to hear about successful deployments. Great work!

Most of the content available in RACHEL has not changed recently so it should be okay to transfer modules to a new RACHEL-Pi image and then check in the “version” page of the admin interface if any module updates are available. This will show you if you have an outdated version of a module and give you the option to download the latest if you want. I usually suggest that to avoid downloading multiple copies for every pi so I think you have a good plan for most content.

KA-Lite is being replaced by the Kolibri service with support and updates for KA-Lite ending, so in the future I would highly suggest getting a Kolibri image and downloading Khan Academy as a Kolibri channel when you have access to a good internet connection. This way you’re deploying with the latest software.

After your request and another request for legacy support of KA-Lite in the latest RACHEL-Pi, I’m going to make a new image with KA-Lite that also includes an updated KA-Lite module installation script. New images are always available at this pinned post but I had to take the latest images down due to some bugs. Those have been resolved so I will let you know when new images are up and provide tutorials/instructions on how to get things going. It should be within the next few days. I’ll let you know when those are up. Hope that makese sense.


Hello @jamesk,
Thanks for your response. I will be on the lookout for the installation script for the RPI 3B+ .

Hello @jamesk,
I wanted to ask how the script is going. I also want to ask about the addition of a WiFi Dongle to an RPI.

I have successfully setup the RPI with a lesser known dongle (RTL8188FU) and it works quite well. Is this enough to make it "work out of the box " with RACHEL? I have not tested it in AP mode but have read about successful tests online.

Please, elaborate on its possibility and steps to be taken to achieve this.
Thank you for your awesome work.

Best Regards,

Hi @Taiwo,

Very sorry for the delay. I had some things happen that kept me from working on RACHEL. I will be working on the image that includes the script today and should have it up tonight or tomorrow for you.


Hello @jamesk,
Thank you very much. I will be expecting it.


Just an update. I have been working on this but there’s an issue with getting KA-Lite to start in the latest Raspbian ( now called raspios ), so I’m just trying to figure out why it won’t start at boot and then I’ll upload an image for you with the script.


Hi @Taiwo,

Can you please try the following image and instructions.

  1. Download rachel-pi_kalite_06_10_2020.7z and flash it to your device
  2. Download or transfer your KA-Lite module to /var/www/modules
  3. Run command “sudo chown www-data:www-data /var/www/modules”
  4. Determine the language code and path of your KA-Lite module. For instance “en-kalite-ess” would be “en” for the language code and “/var/www/modules/en-kalite-ess” for the path
  5. Run command “sudo bash /etc/ka-lite/install-content.sh en /var/www/modules/en-kalite-ess” for example, where en is the language code of the KA-Lite module and /var/www/modules/en-kalite-ess is the full path to the module’s folder

The content should now be installed. Please let me know how this goes. I will make this official and include an MD5 and other things when I hear back. Hope it works and let me know if you have any issues!


Hello @jamesk,
Thank you for your incredible work. I will try this as early as possible tomorrow then give feedback.

Thanks and Best Regards,

1 Like

You’re welcome @Taiwo. I tested with a 3b+ as you mentioned you were using that model but I think it should work with others too if you switch. Hope it goes well!


Hello @jamesk,
It work quite awesomely. I got the KA-lite running in a few hours with minimal effort. Thank you very much for your help.
I did get some error though that might give a little feedback and possibly aid further development.

KA-Lite Content Install: setting up variables.
KA-Lite Content Install: Checking module directory.
KA-Lite Content Install: Module directory exists.
KA-Lite Content Install: stopping kalite.
kalite stopped
KA-Lite Content Install: installing contentpack.
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/base.py", line 224, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/dist-packages/kalite/packages/bundled/fle_utils/django_utils/command.py", line 141, in execute
    super(LocaleAwareCommand, self).execute(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/kalite/packages/bundled/django/core/management/base.py", line 263, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python2.7/dist-packages/kalite/distributed/management/commands/retrievecontentpack.py", line 110, in handle
    self.local(*args, **options)
  File "/usr/local/lib/python2.7/dist-packages/kalite/distributed/management/commands/retrievecontentpack.py", line 190, in local
    assert os.path.isfile(zippath), "%s doesn't seem to be a file." % zippath
AssertionError: /var/www/modules/en-kalite-ess/en-contentpack.zip doesn't seem to be a file.
KA-Lite Content Install: backing up old database.
KA-Lite Content Install: Symlinking new database.
KA-Lite Content Install: Symlinking content.
ln: /root/.kalite/content/assessment: cannot overwrite directory
KA-Lite Content Install: restarting kalite on port 8008
Already stopped. Status was: Stopped
kalite stopped
Running 'kalite start' as daemon (system service)
Going to daemon mode, logging to /root/.kalite/server.log

To access KA Lite from another connected computer, try the following address(es):

To access KA Lite from this machine, try the following address:

I hope this helps. Thank you once again.
Best Regards,

NB: seems like the color is a little bit off. Pardon me.

Glad to hear it works @Taiwo. Were their any issues with Khan Academy after seeing these errors? I’m going to try another installation with the en-kalite-ess module to make sure this doesn’t affect anything.


@jamesk None that I know of .

1 Like

@Taiwo Great. Thank you for the feedback.

Hello @jamesk,

I am in need of the password to the admin part of the webpage. I have tried the previous ones that I have encountered and none worked. Thank you.

Best Regards,

Hi @Taiwo,

The default username/password for the admin page are “admin/Rachel+1”. Let me know if that works.


After completing jamesk’s latest kalite image installation and module transfers I was unable to sign in to KALite’s Admin page that contains the school management setups for “Facilities,Teacher, Reports,” etc.
I had to run the following “kalite manage” superuser command line that allowed me to set up my own admin username/password: sudo kalite manage createsuperuser


You might like to take a look at Kolibri for management. I find it very useful.